Feature #1406

Accessing Authorized Routes Should Redirect to Login Page & Then Back to Page After Successful Login

Added by Pavan Rikhi 12 months ago. Updated 3 months ago.

Status:ClosedStart date:09/05/2019
Priority:NormalDue date:09/05/2019
Assignee:Pavan Rikhi% Done:

100%

Category:GeneralSpent time:-
Target version:v0.7.0 - Misc Pages & UI
Easy Pickings:

Description

1. Log out
2. Try to visit the /account/ page
3. Get redirected to /

Ideally, would redirect to /login/?next=/account/, then on successful login, use the next query param to control the redirect after logging in.


Related issues

Duplicated by SESE Website - Feature #1195: Add Redirects to Login Page Duplicate

Associated revisions

Revision 9fb941c6
Added by Pavan Rikhi 3 months ago

[#1406] Add Login Redirection for Authorized Routes

Improve the flow of authorized pages for anonymous users. When visiting
one of these pages, unauthorized users will be redirected to the Login
page, with a new `redirect` query parameter. After a successful login,
this parameter will be used to redirect user's to the authorized page
they attempted to visit.

Add a parameter to the Route type's Login value for an optional
redirection URL. Parse this from the URL if present. Pass it to the
Auth.Login.view so it can be used to redirect after a successful login.

Modify the redirectIfAuthRequired function so that user's are redirected
to the Login page with the redirect query parameter set to the current
URL.

Closes #1406

History

#1 Updated by Pavan Rikhi 4 months ago

Duplicate of #1195?

#2 Updated by Pavan Rikhi 3 months ago

#3 Updated by Pavan Rikhi 3 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

#4 Updated by Pavan Rikhi 3 months ago

  • Start date set to 09/05/2019
  • Due date set to 09/05/2019

Also available in: Atom PDF